Welcome to Crestfall Gaming

Register now to Crestfall Gaming. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sakritan

Vanilla Sound 12 into 64 channels

52 posts in this topic

Hey guys! As some of you know the original vanilla client only had a measly 16 channels for sound, which made group content and raiding very frustrating because you couldnt hear your own spells/abilities at times. It turns out that the change that you need to edit is found in the wow.exe file in your client folder. It can there be changed to 64 (retail) or even 256 as the max number. It really improves the immersion.
So I was wondering regarding this modified .exe that I have used on previous private servers and that even got an official green light on Kronos. Will we be able to do this on Crestfall as well? I have to ask in case you might use a client file checker thing lik Nostalrius had to see if players use any "modded/added files" or whatever.

While we are on the subject of altering game files. A similar thing here is the awesome Improved Textures patch file that you can simply add into your DATA folder, that changed the models of many creatures to updated wrath-to-wod graphic versions, while the game itself of course remains same. The world terrain or object size etc is not altered whatsoever. Also the texture patch version released is BETA right now so it got a few bugs, but the full release will come end of this year, perfect for Crestfall release 9_9 It makes a perfect mix of playing vanilla content with 2016 graphics instead of 2006.

If people want I can post links to both the modified exe with 256 sound channels and the texture patch for better graphics, but since I dont want to advertise other servers or anything I thought i'd leave links out for now and just ask these questions for the team.

Cheers!


EDIT:
There is a way to change the sound channels without messing with the .exe file. Read through the replies from @Pvt_8Ball. Thank you all for the help!

Edited by Sakritan
8

Share this post


Link to post
Share on other sites

I'm liking aspects of this, just waiting for admin to catch up on the thread. Let's wait and see. Thanks for posting this, appreciated. Mentioning other servers isn't an issue unless it's used to advertise.  

2

Share this post


Link to post
Share on other sites

Ok, thank you :)
I will post links if admin says its ok. Unfortunately I dont have a "neutral site" link right now and I dont want to break any rules and get banned so. :D
But its on Kronos. There are forum pages about the awesome Improved graphic patch that you can find alot of pictures and links to the BETA release. Im still awaiting the full release maybe next months or so. The trhead name is "Improved Models - WiP".

About the 256 sound channels. The thread is named "Question about a modified .exe".. Its pretty cool and a big improvement to the sound, especially for raids its a huge change!

Also a correction: The original vanilla client only supports 12 sound channels at once (even worse!). So as you might imagine, alot of sounds gets cut out because there are to many at once. 

Edited by Sakritan
0

Share this post


Link to post
Share on other sites

Ok. Im going to post the links here. Please remove this post if its against any of the rules. I have no intention to promote any other server. I simply want to provide links to the topic at hand ^_^

Zerocool's awesome Improved texture patch: Check out the pictures all! Remember that the only released version as of now is the BETA that he released back in June. It does have some bugs. The new version will be out end of this year: https://forum.twinstar.cz/showthread.php/103131-Improved-Models-WiP-!
To install. Download the 9 parts and unpack the file into your DATA folder inside your wow installation folder. The patch is safe to try out on most private servers from what I know (again, NOT advertising anything here)
 

Then of course we have this thread about the modified .exe file with 256 sound channels: https://forum.twinstar.cz/showthread.php/94969-Question-about-a-modified-exe
It might seem like it got negative response at first by Dev Chero, but in the end it got green light and even provided a link by the head GM Gurky here on page 4: https://forum.twinstar.cz/showthread.php/94969-Question-about-a-modified-exe/page4

The direct link to the 256 sound channel exe file: https://github.com/Doctorbeefy/Wow.exe-256-Sound/blob/master/WoW.zip?raw=true

Simply put it in your vanilla installation folder (backup if you change your mind or its not allowed or whatever), and enjoy the sweet sound of all spell effects :D

 

1

Share this post


Link to post
Share on other sites

I believe this thread on model-swaps is still relevant and I don't think staff position will have changed.

TL;DR: For every benign use someone can think there's 2 exploitative ones.

As for custom binaries, this hasn't been specifically discussed but I don't see it faring any better for similar reasons.

Edited by Roadblock
0

Share this post


Link to post
Share on other sites

WTB wow.exe with:

1. Frilldistance 777    (now max 256)

 

2. Farclip 5000 (now max 2112)

Edited by Greengrass
0

Share this post


Link to post
Share on other sites
6 hours ago, Svensson said:

No. That was the guy that Magnifican was referring too in the post linked to above. And  clawlancer2 was banned for other things, not the modified exe specifically. It stated: "You were banned for hacking, something we do not do haphazardly. This is not just due to you using a modified client, which is a separate part of the issue and still not the mail reason.". I already read up on that abit and I know plenty of people who used the modified exe on Nost and never got banned for it :) Im not sure its noticeable but if they will use a special scan thing they might detect it and then its instaban of course.

Anyway. In regards to the improved texture patch there even was one version specifically made for Nostalrius so their anticheat could not detect it. I have no interest in cheating anyway but I do realise others might have. I just want nice graphics ^^ I think its fairly easy to catch people who use modelswapping and size changers to make Gnomes big as 10x Taurens in battlegrounds etc.

Lets see what the devs say. The sound exe is the most important thing for me personally. I remember playing with the orignal 12 sounds at first and it was so annoying not hearing your spells and impact effects and stuff, so there is really no going back for me in regards to these sweet 256 sounds. Its like a different game. You can all go and try it out on every other pvt server, u wont get banned anywhere ;)

Read this page https://forum.nostalrius.org/viewtopic.php?f=45&t=5484&start=20
Its the same guy,  clawlancer2, I was referring too. So he didnt get banned for the modified exe alone, and no one else after him did as well.

Edited by Sakritan
0

Share this post


Link to post
Share on other sites

You don't need a custom .exe file, you can just set max sounds in wow's config file or through the console.

Edit: It's soundmaxhardwarechannels 64 and soundsoftwarechannels 64, just pop them in console. You can go higher but that's just what I used. Restart required for changes to take affect.

"/console soundmaxhardwarechannels 64", "/console soundsoftwarechannels 64", then restart.

Edited by Pvt_8Ball
1

Share this post


Link to post
Share on other sites
14 hours ago, Greengrass said:

WTB wow.exe with:

1. Frilldistance 777    (now max 256)

 

2. Farclip 5000 (now max 2112)


I dont think that you can edit frill distance and farclip with the wow.exe though? Isnt that stuff serverside? On plenty of servers they have changed their draw distance and stuff to better handle the lag, like Nost. And that change was made on their part.



Also. I see that the modder that made the improved texture patch that I linked to above, @Zerocool, is actually a member here already. Neat :) (Im wondering whether we can use your file here or not, we will see)

0

Share this post


Link to post
Share on other sites
58 minutes ago, Pvt_8Ball said:

You don't need a custom .exe file, you can just set max sounds in wow's config file or through the console.

Edit: It's soundmaxhardwarechannels 64 and soundsoftwarechannels 64, just pop them in console. You can go higher but that's just what I used. Restart required for changes to take affect.

"/console soundmaxhardwarechannels 64", "/console soundsoftwarechannels 64", then restart.

Are you 100% sure of this? Because ive tried to edit it through the config file and that does nothing. No change ingame. It doesnt recognize it because of our newer hardware compared to 2006.


Here is a post on this

Quote

 

by ovedbeyhan » Tue Mar 31, 2015 5:05 pm

This is a known issue with the 1.12.1 client having reliance on Hardware Accelerated sound channels.
When run on a modern PC and Windows XP+ you do not have any access to harware channels.
You are left with 12 Software channels which means that you can hear only up to 12 sounds at the same time.
This means that if I stand next to 39 other players in a raid while they are fighting mobs i would hear the first 12 sounds.
Sounds such as any casting sound, emotes, mobs and players being hit.
This totally decreases the immersion of 10 years ago.

It's quite baffling really that a Private Server would ban a person for using something that the Vanilla community has made in order to make a 10 year old client work better on modern computers.

By the way if you are wondering why the EXE was modified, it's because this setting is inaccessible on 1.12.1, but in TBC a built in slider was made in the sound options, which behind the scenes was editing a CVar (Console Variable) easily settable via config.wtf.

TBC config.wtf Example:
Code: Select all
SET Sound_NumChannels "X"


My 1.12.1 Logs/Sound.log
3/31 19:49:56.278 Sound::Initialize()
3/31 19:49:56.278 fmod.dll version 3.75 loaded
3/31 19:49:56.298 memory system configured: SMem wrappers
3/31 19:49:56.330 Output system: 2 'Direct Sound'
3/31 19:49:56.330 Driver: 0 'Primary Sound Driver' 00000000
3/31 19:49:56.330 Mixer: 0 'MMXP6'
3/31 19:49:56.330 Buffer size: 50ms
3/31 19:49:56.330 Channels: 12 (12 software, 0 2D hardware(dsound), 0 3D hardware)
3/31 19:49:56.330 Output rate: 44100 Hz
3/31 19:49:56.330 Initialization flags: 00000082
3/31 19:49:56.330 Sound::Initialize() complete

My 2.4.3 Logs/SESound.log:
1/24 22:38:04.016 => Version 2.4.3 (8606) Jul 10 2008
1/24 22:38:04.041
1/24 22:38:04.084 => Setting up Game Sound:
1/24 22:38:04.116 - SESound Engine Init
1/24 22:38:04.156 - FMOD Memory Init
1/24 22:38:04.200 - FMOD System Create
1/24 22:38:04.351 - FMOD version 00040907 detected
1/24 22:38:04.390 - Hardware is DISABLED
1/24 22:38:04.408 - Reverb is DISABLED
1/24 22:38:04.440 - 5 Output drivers detected
1/24 22:38:04.458 --- [0] System Default
1/24 22:38:04.482 --- [1] Speakers (HP Digital Stereo Headset)
1/24 22:38:04.500 --- [2] Realtek Digital Output (Realtek High Definition Audio)
1/24 22:38:04.524 --- [3] Realtek Digital Output(Optical) (Realtek High Definition Audio)
1/24 22:38:04.542 --- [4] S23B550-1 (NVIDIA High Definition Audio)
1/24 22:38:04.565 - Using [0] System Default for Game Output
1/24 22:38:04.583 - Using 32 channels.
1/24 22:38:04.608 - DSPBufferSize = AUTO DETECT
1/24 22:38:04.625 - Detected Control Panel Speaker Mode = STEREO
1/24 22:38:04.649 - Setting WoW Speaker Mode to STEREO
1/24 22:38:04.677 - FMOD System Init OK!
1/24 22:38:04.699 => Game Sound is ready.
1/24 22:38:04.717
1/24 22:38:04.740 => User Settings Report:
1/24 22:38:04.761 - ========= PLAYBACK =========
1/24 22:38:04.782 - Enable All Sound [1]
1/24 22:38:04.800 - Enable SFX [1]
1/24 22:38:04.824 --- Enable Error Speech [1]
1/24 22:38:04.842 --- Enable Emote Sounds [1]
1/24 22:38:04.865 - Enable Music [1]
1/24 22:38:04.886 --- Loop Music [0]
1/24 22:38:04.907 - Enable Ambient Sounds [1]
1/24 22:38:04.925 - Sound at Character [1]
1/24 22:38:04.949 - Sound in Background [0]
1/24 22:38:04.967 - Enable Reverb [0]
1/24 22:38:04.990 -
1/24 22:38:05.011 - ========== VOLUME ==========
1/24 22:38:05.032 - Master Volume [1.00]
1/24 22:38:05.050 - SFX Volume [1.00]
1/24 22:38:05.074 - Music Volume [0.40]
1/24 22:38:05.092 - Ambience Volume [0.60]
1/24 22:38:05.115 -
1/24 22:38:05.136 - =========== MISC ===========
1/24 22:38:05.157 - Sound Channels [32]
1/24 22:38:05.175 - Use Hardware [0]
1/24 22:38:05.199 - Mix Mode 2 [0]
1/24 22:38:05.217 - DSP Buffer Size [AUTO]
1/24 22:38:05.240 - Armor Foley SFX (Self) [1]
1/24 22:38:05.258 - Armor Foley SFX (Others) [1]
1/24 22:38:05.282 => End of User Settings Report
1/24 22:38:08.318
1/24 22:38:08.342 => Shutting Down Game Sound
1/24 22:38:08.418 => Done Shutting Down Game Sound

 


Notice this: By the way if you are wondering why the EXE was modified, it's because this setting is inaccessible on 1.12.1, but in TBC a built in slider was made in the sound options, which behind the scenes was editing a CVar (Console Variable) easily settable via config.wtf.
That CVAR was not put in until TBC.
Edited by Sakritan
0

Share this post


Link to post
Share on other sites

I'll have a look, thanks. Is the limited number of channels also the reason why my game sounds somewhat filtered when running teamspeak? Almost as if it switched to mono

0

Share this post


Link to post
Share on other sites

Have you tried soundsoftwarechannels? It did work for me, I tested before and after. I enabled the dev console, typed sound and pressed tab a few times and it came up, so the CVar is most definately in the game and it most definitely worked for me.

Edited by Pvt_8Ball
0

Share this post


Link to post
Share on other sites

Here my sound.log as proof:

10/2 19:16:20.690  Sound::Initialize()
10/2 19:16:20.690  fmod.dll version 3.75 loaded
10/2 19:16:20.700  memory system configured: SMem wrappers
10/2 19:16:20.720  Output system: 2 'Direct Sound'
10/2 19:16:20.720  Driver: 0 'Primary Sound Driver' 00000000
10/2 19:16:20.720  Mixer: 0 'MMXP6'
10/2 19:16:20.720  Buffer size: 50ms
10/2 19:16:20.720  Channels: 66 (66 software, 0 2D hardware(dsound), 0 3D hardware)
10/2 19:16:20.720  Output rate: 44100 Hz
10/2 19:16:20.720  Initialization flags: 00000082
10/2 19:16:20.720  Sound::Initialize() complete

 

It says 66 because that the number I set soundmaxhardwarechannels and soundsoftwarechannels to, so I think that's proof it works with no custom .exe

Incase it helps, I set the CVars ingame rather than with a config file edit, I added -console to wow's shortcut to enable the console to make things easier.

Edited by Pvt_8Ball
0

Share this post


Link to post
Share on other sites

Oh and yes, you are correct in saying Sound_NumChannels is not in the game, but  soundsoftwarechannels is and does the trick. I guess they probably removed  soundmaxhardwarechannels and soundsoftwarechannels then replaced it with Sound_NumChannels later, but I CBA to check.

Edited by Pvt_8Ball
0

Share this post


Link to post
Share on other sites
On 2016-10-02 at 10:18 PM, Pvt_8Ball said:

snip*

On 2016-10-02 at 10:20 PM, Pvt_8Ball said:

Oh and yes, you are correct in saying Sound_NumChannels is not in the game, but  soundsoftwarechannels is and does the trick. I guess they probably removed  soundmaxhardwarechannels and soundsoftwarechannels then replaced it with Sound_NumChannels later, but I CBA to check.

 
Alright. Incase this works thats awesome mate! No need for modified files and risks of getting banned then. I didnt know running with -console actually did anything. Thats probably why it didnt work for me then I guess. I did try to change the line: "Channels: 12 (12 software, 0 2D hardware(dsound), 0 3D hardware)" to say 64 or 256, but when I restart the game it always resets back to 12. I will sure try this out later.
And surely Crestfall staff cant notice if we run with that -console at the end and it shouldnt mess with the server. I wonder if any other changes can be made this way. I know CVar for grass and frill distance and farclip works in TBC, I have some macros that I made for /console commands in-game that I use in TBC, but in vanilla they do nothing afaik, maybe with -console in the end of .exe it could work. Will have to try some stuff out. Cheers for this!
 

On 2016-10-02 at 10:13 PM, Svensson said:

I'll have a look, thanks. Is the limited number of channels also the reason why my game sounds somewhat filtered when running teamspeak? Almost as if it switched to mono

Ye I dont know about TS specifically but its impossible not to notice how bad the sounds are with 12 channels (the standard way), as soon as you enter group content or whatever. Especially up close in melee its extremely noticeable that when your Slam for example arent making any effect sound on Hit, so you dont know if it did or not unless you look at the combat text . :P
 

Edited by Sakritan
0

Share this post


Link to post
Share on other sites
10 hours ago, Sakritan said:

 Alright. Incase this works thats awesome mate! No need for modified files and risks of getting banned then. I didnt know running with -console actually did anything. Thats probably why it didnt work for me then I guess. I did try to change the line: "Channels: 12 (12 software, 0 2D hardware(dsound), 0 3D hardware)" to say 64 or 256, but when I restart the game it always resets back to 12. I will sure try this out later.

I don't think you're doing it right, it almost sounds like you said you're editting the log file, which is not how it works. Try doing exactly as I say.
Create a shortcut to WoW, in the shortcut properties add the -console launch command by editing the line in "target:" so that it looks something like "*your path to game*\World of Warcraft 1.12\WoW.exe" -console
Then open wow using the shortcut, no need to login, at the login screen just press the key to the left of the 1 key, the key known as Tilde.
Once you have the console open enter sperately:

soundmaxhardwarechannels 64 

and

soundsoftwarechannels 64

You may change the number to what you wish, but 64 is pretty decent. Close the console by pressing Tilde again and quit the game, relaunch the game then close it and check the sound.log file.

 

I'm 90% sure soundmaxhardwarechannels is redundant at this point but I just set it just incase. I did try only setting soundsoftwarechannels by itself and that worked too.

Edited by Pvt_8Ball
1

Share this post


Link to post
Share on other sites
5 hours ago, Pvt_8Ball said:

Once you have the console open enter sperately:

soundmaxhardwarechannels 64 

and

soundsoftwarechannels 64

Doesnt work for me.  Still 12 channels.

0

Share this post


Link to post
Share on other sites
4 minutes ago, Greengrass said:

Doesnt work for me.  Still 12 channels.

You restart the and recheck what it's set at? And how did you test/check?

Edited by Pvt_8Ball
0

Share this post


Link to post
Share on other sites
4 minutes ago, Pvt_8Ball said:

You restart the and recheck what it's set at? And how did you test?

I did exactly what you said.

But i have found another way.

Soundchannels.jpg

0

Share this post


Link to post
Share on other sites
14 minutes ago, Greengrass said:

I did exactly what you said.

But i have found another way.

I wasn't saying you didn't do exactly what I said, I'm just wondering how you tested after to see if it worked or not. But if doing it straight through the config file works, then it doesn't matter, whatever works is fine.

Edited by Pvt_8Ball
0

Share this post


Link to post
Share on other sites

I just learnt that the sound.log file isn't the best way to check how many sound channels you have, because wow doesn't always generate a sound log file so even if you have 64 sound channels enabled the log still might say 12.

0

Share this post


Link to post
Share on other sites
7 hours ago, Pvt_8Ball said:

I don't think you're doing it right, it almost sounds like you said you're editting the log file, which is not how it works. Try doing exactly as I say.
Create a shortcut to WoW, in the shortcut properties add the -console launch command by editing the line in "target:" so that it looks something like "*your path to game*\World of Warcraft 1.12\WoW.exe" -console
Then open wow using the shortcut, no need to login, at the login screen just press the key to the left of the 1 key, the key known as Tilde.
Once you have the console open enter sperately:

soundmaxhardwarechannels 64 

and

soundsoftwarechannels 64

You may change the number to what you wish, but 64 is pretty decent. Close the console by pressing Tilde again and quit the game, relaunch the game then close it and check the sound.log file.

 

I'm 90% sure soundmaxhardwarechannels is redundant at this point but I just set it just incase. I did try only setting soundsoftwarechannels by itself and that worked too.

Ye thats how I did it before, I was just reiterating what I've done before your tips. Will try it your way next time :) (havent gotten the time to check it yet)
 

1 hour ago, Pvt_8Ball said:

I just learnt that the sound.log file isn't the best way to check how many sound channels you have, because wow doesn't always generate a sound log file so even if you have 64 sound channels enabled the log still might say 12.

If it still says 12 then it might be 12 in game too. Gotta test if there really is a noticeable difference in group enviroment etc. And the way 8ball did it you showed us your log above and it did change for you, so it certainly should to be sure.
 

38 minutes ago, Greengrass said:

Frilldistance is not available with CVar commands. I think it is inside of wow.exe

I know its not in CVar, it was added in TBC. But I just wondered if the -console way did enable it, like it does with sound channels. Because without a -command, you cant change sound channels either in-game, not with /console commands. The viewdistance itself is absolutely a server side thing since some servers have farther than others, and some change it (like Nost did). Frill distance might be serverside too, if it is I think we should tell Asura and Darkrasp to increase it because noone has such a bad 2006 computer nowadays (and even IF they do, they can just lower the graphic settings ingame).
Give us longer viewdistance!

Edited by Sakritan
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now